httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Hill" <ddh...@zk3.dec.com>
Subject Re: connect to listener warning message
Date Thu, 11 Apr 2002 19:07:45 GMT
Jeff,

> of course :) (I also remember your other problem where I suggested
> running buildconf to pick up local libtool... what happened with
> that?)

Just got around to trying that (long queue, what with a brand new Apache 2
to play with :-). Yes, the latest libtool installed 1.4.2 and the tarball
builds without a hitch. I saw a thread in dev@ talking about trying to
resync with the public lib tool. Hopefully the libtool sync will make it
into the next spin of the tarball.

> > When I build, I get (and want) IPv6 support, but when I run the image on
a
> > IPv4 only machine, everything seems to work but the POD. Turns out that
this
> > fails because getaddrinfo("::"...) is not providing a usefull value on
an
> > IPv4 only machine, at least as far as the POD connection goes.
>
> Weird.  We only chose "::" because we were able to get an IPv6 socket
> (we tried at run-time in case the build machine and the run machine
> had different capabilities).

A bug somewhere in our network code/implementation ? I wrote a small program
to setup a simple listener using the v6 api and another small program to
connect to it also using the v6 api and was able to reproduce the fact that
I could not connect to :: on the machine without ipv6 enabled. But... on the
server side I did use in6addr_any as opposed to doing a lookup of :: and
then using that addr.

>
> >                               When I hacked
> > listen.c changing "::" to "0.0.0.0" then everything seems to work fine.
I am
> > talking with my network guys about correcting this, but in the mean time
the
> > listen.c hack is simple for me and works.
>
> Before your network guys fix this broken environment, if you have time
> I'd love a little double-checking.  If you could grab the
> /home/trawick/ra/jist executable file from hudson, stick it on that
> machine, and do this:
>
>   start ./jist then run these jist commands:
>
>     socket af_inet6
>     getaddrinfo af_unspec ::
>     getaddrinfo af_inet6 ::
>     (generate EOF to get out of jist)
>
>   and send the output to me

Got same results on 2 machines, one without ipv6 configured. results follow.
Anything else you would like me to try?

thanks,
    Dave

# ./jist
Enter a command (or "help"):
socket af_inet6
Defaulting to type 1...
Defaulting to protocol 0...
The descriptor is 3.
Enter a command (or "help"):
getaddrinfo af_unspec ::
Getaddrinfo results:
IP Addr: ::
Family: 26
Flags: 0
Port: 0
Canonname: "::"
Enter a command (or "help"):
getaddrinfo af_inet6 ::
Getaddrinfo results:
IP Addr: ::
Family: 26
Flags: 0
Port: 0
Canonname: "::"
Enter a command (or "help"):




Mime
View raw message