httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Hill" <ddh...@zk3.dec.com>
Subject Re: connect to listener warning message
Date Thu, 11 Apr 2002 12:34:01 GMT
Jeff,
    remember this one ?

Found my answer to what is going on, have a workaround but not a fix.
Thought you might be interested in what I found.

When I build, I get (and want) IPv6 support, but when I run the image on a
IPv4 only machine, everything seems to work but the POD. Turns out that this
fails because getaddrinfo("::"...) is not providing a usefull value on an
IPv4 only machine, at least as far as the POD connection goes. When I hacked
listen.c changing "::" to "0.0.0.0" then everything seems to work fine. I am
talking with my network guys about correcting this, but in the mean time the
listen.c hack is simple for me and works.

Dave Hill
----- Original Message -----
From: "Jeff Trawick" <trawick@attglobal.net>
To: <dev@httpd.apache.org>
Sent: Saturday, March 30, 2002 8:51 PM
Subject: Re: connect to listener warning message


> "David Hill" <ddhill@zk3.dec.com> writes:
>
> > Hi all,
> >     When I run 2.0.32 on Compaq Tru64 and give it a bit of a load (ok, I
whack it good :-), I get warnings similar to the following looping into the
error log file. I am getting one per second, even well after the load is
removed.I do not get any of these until after the load has been applied for
a 10 seconds or so.
> >
> > [Thu Mar 28 13:11:43 2002] [warn] (49)Can't assign requested address:
connect to listener
>
> "one per second" sounds like idle server maintenance
>
> "can't assign requested address" on a connect sounds like your machine
> is out of ephemeral ports (you were whacking it over loopback I'll
> bet) to assign to the source socket doing the dummy connection
>
> > Any suggestions ?
>
> tune the os to have more ephemeral ports??
>
> --
> Jeff Trawick | trawick@attglobal.net
> Born in Roswell... married an alien...
>
>


Mime
View raw message