httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Marmor <mar...@netmask.it>
Subject Re: Patch: PR#7063
Date Mon, 25 Mar 2002 09:34:17 GMT
Amaury Jacquot wrote:
> 
> Quoting Eli Marmor <marmor@netmask.it>:
> 
> > HTTP GET requests with parameters ("?" and something after it) don't
> > work with mod_auth_digest of Apache 2.0 (I'm using CVS snapshot
> > httpd-2.0_20020323210000.tar.gz).
> 
> Note:
> I had the same problem in the 1.3 branch (patched and it worked)
> I had sent this same patche for it some time ago, but nobody noted
>
> > It seems that the cause is PR#7063.
> >
> > With basic auth, everything works flawlessly, and the only problem is
> > with digest.
> >
> > >From looking at the source, it seems simple to resolve (please commit
> > it):
> >
> > ---------------------------------------------------------------------
> > --- modules/aaa/mod_auth_digest.bug    Mon Mar 25 06:37:39 2002
> > +++ modules/aaa/mod_auth_digest.c       Mon Mar 25 06:38:19 2002
> > @@ -1771,10 +1771,12 @@

And a yet another note:

It is not a bug that "sometime" causes problems;
It is a bug that causes mod_auth_digest to fail ALWAYS (when there are
parameters, of course).
So it looks important for me to commit this patch.
Especially when there is no need to dig into the source, find the
problem, fix it, and test it, but everything is ready and you just have
to commit.

-- 
Eli Marmor
marmor@netmask.it
CTO, Founder
Netmask (El-Mar) Internet Technologies Ltd.
__________________________________________________________
Tel.:   +972-9-766-1020          8 Yad-Harutzim St.
Fax.:   +972-9-766-1314          P.O.B. 7004
Mobile: +972-50-23-7338          Kfar-Saba 44641, Israel

Mime
View raw message