httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject cannot built apache-1.3 with -D_GNU_SOURCE
Date Thu, 21 Mar 2002 04:58:29 GMT
Threaded perl 5.8.0 (still 5.7.3 now) needs to be compiled with
-D_GNU_SOURCE to get the _struct_crypt right. This breaks apache-1.3 build:

gcc -c  -I../os/unix -I../include   -DLINUX=22 -I/usr/include/db1
-DUSE_HSREGEX -DUSE_EXPAT -I../lib/expat-lite -g -O2 -Wall
-Wstrict-prototypes -Wmissing-prototypes -Wshadow -D_GNU_SOURCE
`../apaci` htpasswd.c
htpasswd.c:145: conflicting types for `getline'
/usr/include/bits/stdio.h:103: previous declaration of `getline'
make: *** [htpasswd.o] Error 1

This cannot be fixed in Perl, can this be fixed in apache-1.3?

Building Apache as

CFLAGS="-g -O2 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow
-D_GNU_SOURCE" \
./configure --enable-shared=max --enable-module=most

p.s. mod_perl-2.0/httpd-2.0 have no such a problem.

_____________________________________________________________________
Stas Bekman             JAm_pH      --   Just Another mod_perl Hacker
http://stason.org/      mod_perl Guide   http://perl.apache.org/guide
mailto:stas@stason.org  http://ticketmaster.com http://apacheweek.com
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@perl.apache.org
For additional commands, e-mail: dev-help@perl.apache.org

-- 


_____________________________________________________________________
Stas Bekman             JAm_pH      --   Just Another mod_perl Hacker
http://stason.org/      mod_perl Guide   http://perl.apache.org/guide
mailto:stas@stason.org  http://ticketmaster.com http://apacheweek.com
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/


Mime
View raw message