httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <>
Subject HEADS UP regarding filter names was Re: cvs commit: httpd-2.0/server/mpm/perchild perchild.c
Date Thu, 07 Mar 2002 09:32:18 GMT
On Thu, Mar 07, 2002 at 09:27:17AM -0000, wrote:
> jerenkrantz    02/03/07 01:27:17
>   Modified:    include  ap_mmn.h util_filter.h
>                modules/experimental mod_cache.c mod_case_filter.c
>                         mod_case_filter_in.c mod_charset_lite.c
>                         mod_deflate.c mod_ext_filter.c
>                modules/filters mod_include.c
>                modules/http http_core.c
>                modules/metadata mod_headers.c
>                modules/proxy proxy_ftp.c
>                modules/test mod_bucketeer.c
>                server   core.c util_filter.c
>                server/mpm/perchild perchild.c
>   Log:
>   As hinted on dev@httpd, change filter naming schemes to match our
>   expectations of their usage.

Since we've had so many issues with the filter types recently, I
think it is best to do the rename that we've been hinting at.
This follows from the "three filter types" post from rbb which
gstein and wrowe agreed was goodness (so the idea has been

If you had AP_FTYPE_CONTENT, you should just use AP_FTYPE_RESOURCE.
For those modules that had AP_FTYPE_HTTP_HEADER, you may want
AP_FTYPE_PROTOCOL or AP_FTYPE_CONTENT_SET.  For those filters that
deal with raw protocol issues, they should use _PROTOCOL.  For
those that don't specifically deal with protocols (such as
mod_deflate), they should use _CONTENT_SET.  -- justin

View raw message