httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: I'd like to release 1.3.24...
Date Sat, 02 Feb 2002 19:41:52 GMT
Dale Ghent <daleg@elemental.org> writes:

> On Sat, 2 Feb 2002, Jim Jagielski wrote:
> 
> | I'd like for us to consider releasing 1.3.24 specifically for the Solaris
> | pthread fix. I offer to be RM. I'll update STATUS for voting and comments.
> 
> I don't know, I think it might be premature to do that.
> 
> I still think that it's a bad idea to unconditionally include libpthread
> on Solaris builds in cases where HPSA is not enabled, which would be
> (relatively) rare situations because HPSA is not the default for Solaris.

what the heck is HPSA?

I thought you wanted pthread mutex to be the default on Solaris and
not just a choice (like it is now)?  Was that somebody else?

> The effects of this should at least be tested first, before releasing to
> the general populace. I vollunteer to do this on Solaris 8.
> Unfortuanately, I just ditched my only 2.6 box, so testing the effects on
> there would have to be done by someone else.

In general I'm cool with slowing down on this, but first I'd like to
understand more about your concern with HPSA.  The code is completely
busted as-is.  Some people have ineffective accept serialization,
others have catastrophic failure, but certainly most people are
unaffected.

I hope to have a 2.7 test report in the next few days (a situation
where someone is hurting now and will have their httpd replaced with
one that pulls in -lpthread).

-- 
Jeff Trawick | trawick@attglobal.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message