httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale Ghent <da...@elemental.org>
Subject Re: I'd like to release 1.3.24...
Date Sat, 02 Feb 2002 19:32:17 GMT
On Sat, 2 Feb 2002, Dale Ghent wrote:

| I still think that it's a bad idea to unconditionally include libpthread
| on Solaris builds in cases where HPSA is not enabled, which would be
| (relatively) rare situations because HPSA is not the default for Solaris.

Replying to my own email here.

I figured, that since we're halfway there by adding -lpthread to LIBS, we
might as well go all-out and make it useful to us on Solaris.

Attached is a patch to add -DUSE_PTHREAD_SERIALIZED_ACCEPT to CFLAGS for
Solaris.

I've tested HPSA sucessfully on Solaris 8, and recently, with 2.6. Both
had expected results and no unexpected side-effects.

/dale

Mime
View raw message