httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Bannert <aa...@clove.org>
Subject Re: Using Apache 1.3 modules with 2.0 was Re: Please help kill httpd-2.0 bugs...
Date Wed, 27 Feb 2002 17:32:34 GMT
On Wed, Feb 27, 2002 at 12:20:51PM -0500, Greg Marr wrote:
> Not on Windows.  You will not be able to even load the module.  The 
> LoadLibrary call will fail, since the module is linked against 
> functions that don't exist.  That is a standard system error message 
> from using LoadLibrary to load a DLL when a required dependency 
> doesn't exist.

In that case we should simply make the error more descriptive:

"Failed to load module. Perhaps this module was compiled for Apache 1.3?"

-aaron

Mime
View raw message