httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Sussman <mydd...@vishnu.vidya.com>
Subject Re: prefork segfaults under load
Date Wed, 06 Feb 2002 20:21:53 GMT
On Tue, Feb 05, 2002 at 10:45:07PM -0500, Jeff Trawick wrote:
> Adam Sussman <myddryn@vishnu.vidya.com> writes:
> 
> > I'm seeing a lot of error messages like this in my error log under load with
> > lots of children (1300 or so):
> > 
> ...
> > #0  pthread_sighandler (signo=11, ctx=
> >       {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh
= 0, edi = 1074716232, esi = 0, ebp = 3221222696, esp = 3221222656, ebx = 1074726616, edx
= 1, ecx = 0, eax = 0, trapno = 13, err = 0, eip = 1074677988, cs = 35, __csh = 0, eflags
= 66070, esp_at_signal = 3221222656, ss = 43, __ssh = 0, fpstate = 0x0, oldmask = 2147483648,
cr2 = 0})
> >     at signals.c:87
> > #1  <signal handler called>
> > #2  __pthread_reset_main_thread () at internals.h:372
> > #3  0x400e40e5 in __fork () at ptfork.c:92
> > #4  0x080762e8 in make_child (s=0x80b9378, slot=1343) at prefork.c:770
> > #5  0x0807671b in perform_idle_server_maintenance (p=0x80b7578) at prefork.c:963
> > #6  0x08076a7e in ap_mpm_run (_pconf=0x80b7578, plog=0x80e9640, s=0x80b9378) at
prefork.c:1120
> > #7  0x0807d5d2 in main (argc=1, argv=0xbffffb54) at main.c:501
> > #8  0x4010d177 in __libc_start_main (main=0x807cca4 <main>, argc=1, ubp_av=0xbffffb54,
init=0x805e22c <_init>, 
> >     fini=0x809e010 <_fini>, rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffffb4c)
at ../sysdeps/generic/libc-start.c:129
> > (gdb)   
> 
> I would try adding "--disable-threads" to the configure invocation to
> see if that helps.  It looks like the pthreads library is puking.
> 
>   make distclean
>   ./configure --disable-threads old-parameters
>   make && make install
> 

That fixed the problem.  So, is this the right solution?  Should configure always
assume --disable-threads when it sees --with-mpm=prefork?

Given that this problem does not show up with low numbers of children, I am kind
of wondering if disabling threads is just covering up some problem that should
not affect prefork.

Thoughts?

-adam

Mime
View raw message