httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: cvs commit: httpd-2.0/modules/proxy config.m4
Date Thu, 20 Dec 2001 12:55:50 GMT
"Victor J. Orlikowski" <vjo@dulug.duke.edu> writes:

> The issue is as follows: mod_proxy_{connect,ftp,http} all depend on
> symbols in mod_proxy. Run-time linking (as added by Jeff) fixes the
> problem for most modules (including DAV and DAV_fs, which depends on
> DAV), but proxy is still being the odd man out, for whatever reason.
> This is (likely) not libtool's fault this time (I can't believe I just
> typed that), but the issue has not yet been properly diagnosed.

Is it possible that we're getting bit by make_exports.awk not being
able to grok declarations that span lines?  (just a wild guess)

What is the symptom?  link failure?  segfault?

> However, I believe Jeff is speaking to the libtool guys re: their
> handling of shared {libraries,objects} on AIX, w.r.t. other issues.

I took a break from that trying to get Apache to deal with the
currently-available libtool version.  We're not done yet, though
hopefully we're closing in on it.  Hopefully I can get some time to
help identify some needed changes to libtool for AIX.  Note that I'm
*extremely* uninterested in any sort of situation where standard
libtool can't be used to build Apache on AIX.

I suspect Justin is interested in the library dependency thing that
failed on AIX back before we were using rtl.  I posted something to
dev@apr.apache.org a few days back showing the results when I tried to
do the same thing after we switched to rtl.

-- 
Jeff Trawick | trawick@attglobal.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message