httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <>
Subject conn_rec apr_bucket_alloc_t* field
Date Fri, 28 Dec 2001 04:10:29 GMT

Anybody have preferences as to what I name the field I'm adding to the
conn_rec to store the apr_bucket_alloc_t*?  It's used _everywhere_, so
short and sweet would be preferable.  Right now in the patch it's called
c->balloc, but that seems a bit wonky.  At least it's unique enough that I
can search-and-replace it with something else easily.  ;-)  Ideas?  A
couple of people have suggested the more verbose c->bucket_alloc or
something like that, but this really is used _everywhere_.  The less
obtrusive, the better.  Too bad there's nothing as succinct as "c->pool"
that we could name it... that would be ideal.   What about c->bmemsys or
something?  Ideas?


   Cliff Woolley
   Charlottesville, VA

View raw message