httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Ames <grega...@remulak.net>
Subject read errors in 2.0.30
Date Thu, 20 Dec 2001 22:32:58 GMT
httpd 2.0.30-dev was in production for about 11 minutes on daedalus. 
Then I noticed a bunch of unusual errors in the log, so I moved us back
to 2_0_28.  

They all seem to deal with reading lines from the input filters.  There
were 85 "request failed: error reading the headers" logs in 11 minutes,
compared to just 8 on 2_0_28 so far today.  There were a lot of
complaints about methods and URIs, with some funky stuff printed out as
the request:

[Thu Dec 20 12:40:45 2001] [error] [client 212.171.216.10] Invalid
method in request 1.1
[Thu Dec 20 12:42:54 2001] [error] [client 212.171.216.10] Invalid URI
in request j/graphics/ext-6j/graphics/ext-6j/graphics/ex
[Thu Dec 20 12:42:54 2001] [error] [client 212.171.216.10] Invalid URI
in request ces2-j/graphics/ces2-j/graphics/ces2-j/graphics/c
[Thu Dec 20 12:44:16 2001] [error] [client 128.226.140.172] Invalid URI
in request Connection: Keep-Alive, TE
[Thu Dec 20 12:46:30 2001] [error] [client 207.159.169.134] Invalid URI
in request graphicsgraphicsgraphicsgraphicsgra
[Thu Dec 20 12:47:14 2001] [error] [client 211.252.182.129] Invalid URI
in request Host: www

Notice the repetition of pieces of valid URIs and fragments of headers.

We had some changes to ap_getline between the two builds; it might be
worth looking at them again.  Any other ideas?  I don't see these
failures with log replay.

Greg

Mime
View raw message