httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: unixd_accept
Date Mon, 24 Dec 2001 18:01:17 GMT
On Mon, Dec 24, 2001 at 09:00:09AM -0800, Ryan Bloom wrote:
> On Monday 24 December 2001 03:58 am, David Reid wrote:
> > This is defined, but how about we rename it to something without the unixd_
> > portion so that it's simply a more generic os function, something like
> > ap_os_accept?  I ask as I added a beosd_accept and that seems a little
> > clumsy as in the worker MPM I have to then add a series of #if's to get the
> > function used, so simply having an ap_os_accept would solve the problem and
> > seems like an easier way to go.
<snip, snip>
> I have no problem with doing this, but we need to keep this logic out of the
> main server.  The whole point of the unixd_* functions is that they don't make
> any sense for Windows, and possibly for OS/2.  If you can use all or even
> most of those functions, then why don't you just rename your platform
> to unixd, and abstract out the differences.

Silly question, but why isn't this a hook that various platforms
can implement?  I kind of thought that was the purpose of hooks.
(And, I believe that hooks may not be there, so nothing will run -
perfect for Win32 or OS/2).  -- justin


Mime
View raw message