httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sterling <sterl...@covalent.net>
Subject Re: 2.0.28-beta release?
Date Tue, 13 Nov 2001 18:58:04 GMT
You just need to comment out the 401 error document -

sterling

On Tue, 13 Nov 2001, Cliff Woolley wrote:

> On Tue, 13 Nov 2001, Justin Erenkrantz wrote:
>
> > I'm not sure what the policy is here (this is really up to Greg as
> > RM), but if 2.0.28 makes it to beta (which I think it has with
> > three +1s), can we add that patch that fixes the header filters
> > with ap_die into the beta tarball (modules/http/http_request.c)?
> >
> > I know that we can't touch the 2.0.28-alpha tarball, but I seem
> > to recall someone saying we could touch the next-level tarball
> > (i.e. -beta).
> >
> > This would resolve a problem that has been fixed and a bunch
> > of people have reviewed this (me, Ryan, and Cliff).
>
> If we're willing to touch the tarball at all, a less obtrusive change
> might be to just comment out the .html.var line for ErrorDocument 401 in
> the default config file, which also fixes (works around) the problem (I
> tested it).  But I'm also willing to just document in the release notes
> that if you want to use mod_auth, you need to comment that line out for
> now.
>
> [PS: Do _all_ of the errordocument .html.var lines need to be commented
> out for the workaround to be effective?  I didn't try any of the other
> errors, because I'd've expected httpd-test to fail miserably if any of the
> others besides 401 (and maybe 403) were affected by this, and it didn't.]
>
> --Cliff
>
>
> --------------------------------------------------------------
>    Cliff Woolley
>    cliffwoolley@yahoo.com
>    Charlottesville, VA
>
>
>



Mime
View raw message