httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "MATHIHALLI,MADHUSUDAN (HP-Cupertino,ex1)" <madhusudan_mathiha...@hp.com>
Subject RE: [PATCH] Makefile.in
Date Tue, 20 Nov 2001 22:50:25 GMT
[Oops.. I hit the send before I finished typing..]

the requirement is pretty simple here : I enable mod_ssl as a DSO, and if I
want to bring up the server in SSL mode, I use "apachectl startssl".. If I
DON'T want to bring up the server in SSL mode, I'll use "apachectl start"..
But, since mod_ssl is linked as a DSO, the line "LoadModule ssl_module ..."
appears irrespective of how the server is started - this leads to problems,
because the other parameters required for mod_ssl to initialize properly
(ex. random seed) is not defined with "apachectl start"... So, I guessed
that it makes sense to put the "LoadModule ssl_module..." within the
"IfDefine.." block..

-Madhu

-----Original Message-----
From: MATHIHALLI,MADHUSUDAN (HP-Cupertino,ex1)
[mailto:madhusudan_mathihalli@hp.com]

I have SSL support, but I don't want to bring up the server in SSL mode  -
how do I do that without touching the httpd.conf file ?..

-Madhu


-----Original Message-----
From: Aaron Bannert [mailto:aaron@clove.org]
Sent: Tuesday, November 20, 2001 2:41 PM
To: dev@httpd.apache.org
Subject: Re: [PATCH] Makefile.in


On Tue, Nov 20, 2001 at 05:18:35PM -0500, MATHIHALLI,MADHUSUDAN
(HP-Cupertino,ex1) wrote:
> Hi,
> 	'just wondering if anybody would be interested in this patch.. If
> SSL is enabled as DSO, then it puts the "LoadModule ssl_module..." within
> the <IfDefine SSL>...</IfDefine> block.. This enables the user to just
issue
> a "apachectl start".. 

I don't quite understand. If you compiled SSL support in and you have DSO
you get the LoadModule line. If you didn't want that, take it out of your
config. What does this solve, exactly?

-aaron

Mime
View raw message