httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Bannert <aa...@clove.org>
Subject Re: cvs commit: httpd-2.0/modules/ssl config.m4
Date Wed, 14 Nov 2001 19:23:27 GMT
Furthermore, manually compiling mod_ssl as a DSO reveals that I can
indeed add -lssl and -lcrypto to the libtool flags, and those libraries
will be found when mod_so is loaded. I'm not so sure this works for all
other platforms, though (and I'm quite sure AIX won't play that game).
Any suggestions?

Does someone more creative with autoconf than myself want to take a stab
and detecting -lssl/-lcrypto when mod_ssl is enabled and adding those
flags to the LDFLAGS for mod_ssl.la?

-aaron


On Wed, Nov 14, 2001 at 06:56:18PM -0000, aaron@apache.org wrote:
> aaron       01/11/14 10:56:18
> 
>   Modified:    modules/ssl config.m4
>   Log:
>   Turns out this is causing problems on my linux box (libtool 1.3.5), so
>   I'm going to remove it until I or someone else can come up with a better
>   way to check for and link against libssl and libcrypto for mod_ssl.so.
>   
>   Revision  Changes    Path
>   1.7       +1 -1      httpd-2.0/modules/ssl/config.m4
>   
>   Index: config.m4
>   ===================================================================
>   RCS file: /home/cvs/httpd-2.0/modules/ssl/config.m4,v
>   retrieving revision 1.6
>   retrieving revision 1.7
>   diff -u -r1.6 -r1.7
>   --- config.m4	2001/11/07 19:42:07	1.6
>   +++ config.m4	2001/11/14 18:56:18	1.7
>   @@ -77,7 +77,7 @@
>    ssl_util_table.lo dnl
>    "
>    dnl #  hook module into the Autoconf mechanism (--enable-ssl option)
>   -APACHE_MODULE(ssl, [SSL/TLS support (mod_ssl)], [$ssl_objs \$(EXTRA_LIBS)], , no,
[
>   +APACHE_MODULE(ssl, [SSL/TLS support (mod_ssl)], $ssl_objs, , no, [
>        APACHE_CHECK_SSL_TOOLKIT
>    ])

Mime
View raw message