httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hiten pandya <hpan...@lycos.co.uk>
Subject regarding: apache configuration
Date Thu, 01 Jan 1970 00:00:00 GMT
Type Bits/KeyID Date User ID
pub 1024/2C6352C9 2001/10/08 Hiten Pandya 
<hpandya@lycos.co.uk>

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: 2.6.3ia

mQCNAzvB2gEAAAEEAMV8qmHRnf55GdiI839C4tjsG/JthcwHCftlM9HbALWAcG9Y
KMqyz6EFOi0ErBWWHX+/YzyZVDwPwpLUaayWx01vlO8YqfEXnykinfz4owfHqsyq
MM+D7CfaKrkte0GLNXFRNauaqy5cXUgg6VSC5+pJbnlaszSSaMAHD4IsY1LJAAUT
tCJIaXRlbiBQYW5keWEgPGhwYW5keWFAbHljb3MuY28udWs+iQCVAwUQO8HaAcAH
D4IsY1LJAQHEfAP9E9JdUajVnHmLBFK0Qpn0zXtxUS8a3NMZvcMFmUDgwe7nCgvV
0nljOqgnMpUa2gNqmZjkRfGTgEozUkiTvagkOSPHxjt778BWrc2F6rRXVzohLRVt
VZyKK+9FcipKrEJyDDw4Kx31N8Chu+WP+ce05tgLJjSiuTBPX5qJNW3eoDE=
=5hW/
-----END PGP PUBLIC KEY BLOCK-----


hello everyone
greetings,

the problem is not in the config*.m4 scripts,

its coming from the script which, generate's the configure 
scripts at whole.

the reason to this is:

any APACHE_MODULE statement i have noticed, gets generated 
two times. for example: (correct me if i am wrong)

-------------------------------------------------
APACHE_MODULE(so, DSO capability, , , static)
produces:

ac_help="$ac_help
 --enable-so DSO capability"
ac_help="$ac_help
 --enable-so DSO capability"

--------------------------------------------------

and:

APACHE_MODULE(cgid, CGI scripts, , , yes)
APACHE_MODULE(cgi, CGI scripts, , , no)

produce:

ac_help="$ac_help
 --disable-cgid CGI scripts"
ac_help="$ac_help
 --enable-cgi CGI scripts"
ac_help="$ac_help
 --disable-cgi CGI scripts"
ac_help="$ac_help
 --enable-cgid CGI scripts"

-----------------------------------------------------


The other big problem, is that, sometimes, suppose an 
administrator might get confused according to the 
Descriptions provided for these options.

For example:

Disable CGI-D should be "Disable CGI Scripts"
not just "CGI Scripts"

or any other option like that.

Thank You,

Please send me your considerations on this matter because i 
am working around to solve this bug,

(i am a newbie on this..)

Greetings,
Hiten Pandya <hpandya@lycos.co.uk>
______________________________________________________
Free E-mail - Lycos UK - http://www.lycos.co.uk
Get your domain for £9.90 - http://lycos.uk.domainnames.com/default.asp?caller=lycos_ef
Play now to win £1 Million - http://ad.uk.doubleclick.net/clk;3386758;6457074;y?http://www.thedailydraw.com/mainframe.cfm?source=lycos


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message