httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: Currently known issues with 2.0.23 (very few! :)
Date Wed, 08 Aug 2001 14:00:51 GMT
Justin Erenkrantz <jerenkrantz@ebuilt.com> writes:

> > 5) There is a known build problem when using GNU make version 3.77
> >    on some systems, which appears to be a bug in that version of gmake.
> >    Upgrading to a newer version of gmake fixes the problem.
> 
> AFAIK, this is a problem.  I don't care to spend any time fixing this
> when an upgraded version solves the problem.  If someone wants to
> submit a patch, but this is really just a broken make.  We should
> have a "Platform Notes" section in the README or INSTALL (where?).
> It'd be nice to also add the note about the broken Linux 2.4.3 stuff 
> I stumbled across a few weeks ago.  -- justin

I still hope to eventually fix server/Makefile.in so it will work on
the two systems where I've had problems (any OS/390 and a particular
Solaris 8/gmake ??? combination*).  We're using a non-portable feature:
some/any form of expansion of wildcards in a dependency list.

I dunno exactly which problem Cliff refers to; I'm guessing he refers
to the one where running make twice works around the problem.

*maybe this is a gmake bug where an upgrade is appropriate, but since
 it has to be fixed anyway for another platform's make it doesn't make
 much difference to me
-- 
Jeff Trawick | trawick@attglobal.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message