httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Ames <grega...@remulak.net>
Subject Re: [PATCH] mod_include fix (only show stopper in 2.0.24...)
Date Fri, 17 Aug 2001 18:51:20 GMT
Greg Ames wrote:
> 
> noticed this in the error_log on my ThinkPad:
> 
> [Fri Aug 17 13:11:24 2001] [notice] caught SIGTERM, shutting down
> [Fri Aug 17 13:11:24 2001] [notice] seg fault or similar nasty error
> detected in the parent process

I can't make any sense out of the dump, nor can I re-create the problem,
even with Jeff's one-liner to mod_include backed out.  I'm writing this
one off as sunspots, gamma rays or panty hose.

Greg

p.s. please speak up if this makes more sense to you.

(gdb) bt
#0  0x40009a61 in ?? ()
#1  0x4000d360 in ?? ()
#2  0x4000d510 in ?? ()
#3  0x401160fe in ?? ()
#4  0x4014fb68 in ?? ()
#5  0x0808fd19 in apr_palloc (a=0x80e4c74, reqsize=1024) at
apr_pools.c:1100
#6  0x0808fea2 in apr_pool_userdata_get (data=0x80c0a0c, key=0x80c0a0c
"",
    cont=0xbffff638) at apr_pools.c:1222
#7  0x0808ff00 in psprintf_flush (vbuff=0x80c0a0c) at apr_pools.c:1289
#8  0x0808fe8c in apr_pool_userdata_get (data=0x80be9fc,
    key=0x400 <Address 0x400 out of bounds>, cont=0xbffff65c)
    at apr_pools.c:1221
#9  0x0808ff00 in psprintf_flush (vbuff=0x80be9fc) at apr_pools.c:1289
#10 0x08067d15 in usage (process=0x80bea74) at main.c:258
#11 0x08068425 in get_addresses (p=0x1, w_=0xbffff754 "×øÿ¿",
    paddr=0xbffff75c, default_port=134600058) at vhost.c:220
#12 0x4013f0de in ?? ()

Mime
View raw message