httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bloom <...@covalent.net>
Subject Re: ARGH! Libtool 1.4 breaks our build!
Date Tue, 21 Aug 2001 20:58:09 GMT

I have no idea how this could work for you.  As a part of our configure
script, we use ltconfig to create shlibtool.  But, libtool 1.4 removes ltconfig,
so we can't create shlibtool.  Since our build system relies on shlibtool
to build DSO's, this really shouldn't work.

Did you have libtool 1.3.x installed the first time you tried to build
shared libraries?

Ryan

On Tuesday 21 August 2001 13:51, Ian Holsman wrote:
> my configure script is below.
>
> in the buildconf it says 1.4
>
> rpm -q libtool
> gives
> libtool-1.4-6
>
> I just did a make clean, pulled the latest CVS HEAD and ran the below.
> it built, installed, and is running now without a hitch.
>
> to be doubly sure... I'm running make distclean now and re-doing it
>
>
> --configure script--
> #!/bin/bash
> #
> ./buildconf
> export OPTIM="-O2"
> ./configure \
>     --enable-so \
>     --prefix=/usr/local/apache \
>     --enable-shared \
>     --enable-proxy \
>
> --enable-mods-shared=rewrite,status,spelling,unique_id,headers,expires,user
>track,proxy,file-cache,cgi,cgid \
>     --enable-rewrite=shared \
>     --enable-status=shared \
>     --enable-spelling=shared \
>     --enable-unique_id=shared \
>     --enable-headers=shared \
>     --enable-expires=shared \
>     --enable-usertrack=shared \
>     --enable-proxy=shared \
>     --with-z \
>     --enable-gz=shared \
>     --enable-file-cache=shared \
>     --enable-cgi=shared \
>     --enable-status=shared \
>     --enable-cgid=shared \
>     --enable-mmap_static=shared  \
>     --disable-oid \
>
> Ryan Bloom wrote:
> >Unless you are trying to create shared modules, you won't see the
> >problem
> >
> >Ryan
> >
> >On Tuesday 21 August 2001 13:26, Ian Holsman wrote:
> >>hmm..
> >>
> >>I'm running quite happily with libtool 1.4
> >>All i did was remove all the 'libtool' crud files which were in the
> >>apache CVS tree,
> >>re-ran buildconf and libtool 1.4 happily did it's work.
> >>
> >>(also did it to get php to run on my home box (redhat 7.1))
> >>
> >>Ryan Bloom wrote:
> >>>Unfortunately, PHP4 requires libtool 1.4, but libtool 1.4 has removed
> >>>ltconfig, so I can't create shlibtool, so I can't build shared modules.
> >>>I HATE LIBTOOL!
> >>>
> >>>BTW, I am working on fixing this, but after two days, I just had to
> >>> gripe.
> >>>
> >>>Ryan
> >>>______________________________________________________________
> >>>Ryan Bloom                        	rbb@apache.org
> >>>Covalent Technologies			rbb@covalent.net
> >>>--------------------------------------------------------------

-- 

______________________________________________________________
Ryan Bloom                        	rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------

Mime
View raw message