httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Bloom <...@covalent.net>
Subject Showstopper!
Date Mon, 06 Aug 2001 23:09:01 GMT

One of our QA guys at Covalent has just let me know that SSI's are broken in 2.0.  Basically,
if, else,  elif, and that family of SSI's don't seem to do what they are supposed to do.

BTW, he caught these using the perl test-framework in httpd-test.  The test cases he was using
can be found in httpd-test/perl-framework/t/htdocs/modules/include/if*.shtml. 

All of these tests work correctly under Apache 1.3.

For example:

<!--#if expr="\"1\" = \"1\""-->
pass
<!--#endif -->
<!--#if expr="\"1\" = \"2\""-->
fail
<!--#endif -->

Doesn't work correctly.

Ryan
_____________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
Covalent Technologies			rbb@covalent.net
-----------------------------------------------------------------------------

Mime
View raw message