httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Farag, Hany M (Hany)" <hfa...@lucent.com>
Subject RE: Adding modules to Apache2.0 Beta problem !
Date Tue, 24 Jul 2001 17:31:27 GMT

 Hi,
 I was trying to add a module to apache 2.0 following the instructions in
 "writing apache modules in perl and c" which is using apache 1.3.4.
 Apparently there are differnet commands, but anyway i used the  -help nad
 used the following command to configure apache 2.0 with my simple module:
 ./configure --with-module=site/mod_test.c
 when I run configure, it succeed but when i run the make script afterwards
 I get the following error

  Making all in mappers
  make[2]: Entering directory
 /home/hfarag/Apache2/httpd-2.0/modules/mappers'
  make[3]: Entering directory
 /home/hfarag/Apache2/httpd-2.0/modules/mappers'
 make[3]: Nothing to be done for `local-all'.
 make[3]: Leaving directory
 /home/hfarag/Apache2/httpd-2.0/modules/mappers'
 make[2]: Leaving directory
 /home/hfarag/Apache2/httpd-2.0/modules/mappers'
 make[1]: Leaving directory `/home/hfarag/Apache2/httpd-2.0/modules'
 Making all in support
 make[1]: Entering directory `/home/hfarag/Apache2/httpd-2.0/support'
 make[2]: Entering directory `/home/hfarag/Apache2/httpd-2.0/support'
 make[2]: Nothing to be done for `local-all'.
 make[2]: Leaving directory `/home/hfarag/Apache2/httpd-2.0/support'
 make[1]: Leaving directory `/home/hfarag/Apache2/httpd-2.0/support'
 make[1]: Entering directory `/home/hfarag/Apache2/httpd-2.0'
 make[1]: *** No rule to make target
 modules/site/mod_hello.c/mod_hello.la',
 needed by `httpd'.  Stop.
 make[1]: Leaving directory `/home/hfarag/Apache2/httpd-2.0'
 make: *** [all-recursive] Error 1

Then i went to the Apache 20 documentation on
http://httpd.apache.org/docs-2.0/mod/mod_example.html

and followed the following steps:
Compiling the example module
To include the example module in your server, follow the steps below: 

1.Uncomment the "AddModule modules/example/mod_example" line near the bottom
of the src/Configuration file. If there isn't one, add it; it should look
like this: 
     AddModule modules/example/mod_example.o
    
2.Run the src/Configure script ("cd src; ./Configure"). This will build the
Makefile for the server itself, and update the 


But there was no commented AddModule, so i added one  and then did:
./configure


I got the following error:
 ./apachectl start
Syntax error on line 944 of /usr/local/apache2/conf/httpd.conf:
Invalid command 'AddModule', perhaps mis-spelled or defined by a module not
included in the server configuration
./apachectl start: httpd could not be started


any ideas what I'm doing wrong?

Thanks

Mime
View raw message