httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <ad...@rowe-clan.net>
Subject Re: file/mmap buckets, subrequests, pools, 2.0.18
Date Fri, 01 Jun 2001 17:42:46 GMT
Is this specific to a platform?  Perhaps sendfile had been disabled in 2.0.16,
and was enabled by all the buildconf cleanup?

----- Original Message ----- 
From: "Cliff Woolley" <cliffwoolley@yahoo.com>
To: <new-httpd@apache.org>; <trawickj@bellsouth.net>
Sent: Friday, June 01, 2001 12:33 PM
Subject: Re: file/mmap buckets, subrequests, pools, 2.0.18


> On Fri, 1 Jun 2001, Jeff Trawick wrote:
> 
> > We finally died back in the main request processing because we
> > referenced an mmap bucket whose apr_mmap_t used the same pool as the
> > apr_file_t.  The apr_mmap_t had been overlaid because the storage was
> > released at the end of the main request and subsequently reused for
> > some other purpose.
> > ...
> > Any ideas about what recent changes might have introduced or exposed
> > this problem?
> 
> Hmmm... ugly.  It seems like a pretty basic design issue to me.  No
> changes were made between 2.0.16 and 2.0.18 to the buckets code itself
> that would have affected this (there were only three substantive commits
> to the buckets code in that time... two by me and one by Jeff... all
> unrelated).  If anything really did change in that time that broke this,
> it's in Apache.
> 
> --Cliff
> 
> --------------------------------------------------------------
>    Cliff Woolley
>    cliffwoolley@yahoo.com
>    Charlottesville, VA
> 
> 
> 


Mime
View raw message