httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From System Administrator <ad...@netbiz.net.au>
Subject Can't compile apache-1.3.20-ssl-2.84
Date Tue, 29 May 2001 10:58:16 GMT
Hi,

Please forgive me if this is the wrong place to send this email. If it
is could someone please point me to the correct place... Thanks

I am trying to compile the latest apache with the latest Mod SSL (2.84),
on a Linux server (kernel 2.2.17, slackware distribution), with the
latest GCC compiler (2.95 I think), and with mm-1.1.3, Perl-5.6.1,
openSSL-0.9.6a, as per the install docs. I originally started with perl
5.005-003, GCC 2.7.2.2, but during the compile attempts have upgraded
these.

I've tried with and without mm. Always completely removing the
directories and re-extracting from the tarballs to ensure a clean
compile.

Every attempt results in the following...

ssl_engine_mutex.c: In function 'ssl_mutex_sem_create'
ssl_engine_mutex.c:297: incompatible type for argument 4 semctl
ssl_engine_mutex.c:306: incompatible type for argument 4 semctl
ssl_engine_mutex.c: In function 'ssl_mutex_sem_remove'
ssl_engine_mutex.c:338: incompatible type for argument 4 semctl
make[4]: *** [ssl_engine_mutex.lo] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
etc...
etc...

Anyone know what the solution is?



--
Are you in business?
Are you able to be found worldwide?
Get into the premier online directory for only $52 per year
Quickpages Business Directories
http://www.quickpages.com.au/netbiz

Mime
View raw message