httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Ames <>
Subject Re: Scoreboard redesign
Date Mon, 14 May 2001 15:23:29 GMT
"Paul J. Reder" wrote:
> The basic idea is to separate the parts of the scoreboard that Apache
> needs for process/thread management from the part that mod_status
> needs for server-status.

> The basic data structures are as follows:

Paul - a few nits.  Mostly they apply to code which is already

* parent_score:  that describes a process, not a parent.  Let's rename
it process_score.  

* life_status: it's only used by prefork today, but I think it is
describing what's going on with the process, as opposed to the worker. 
And it's needed even when mod_status isn't loaded.  Could we move it
into the process_score/parent_score and call it process_status (so we
don't confuse it with "status" in worker_score/short_score)?   

Along the same lines, we should have a comment in worker_score that this
structure contains fields which are only needed when mod_status is
active, since that's where we're going.  

* new_scoreboard: no longer referenced.  Earlier in 2.0, it consumed
mass quantities of shared memory which was unused.  Let's nuke it (and
STATUSES_PER_CONNECTION while we're at it).  

Overall, +1 on the concept.  This should help the threaded MPMs scale,
once we take full advantage of its potential. 


View raw message