httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject Re: mod_tls support
Date Mon, 09 Apr 2001 22:03:11 GMT

The config.m4 stuff for mod_tls still requires major work.  In fact, that
whole module does.  The last time I checked, it only worked with OpenSSL
0.9.6 or better.  A lot of the config.m4 logic is to try to find the SSL
libraries, and the SSL headers, for OpenSSL, and the RSA BSafe libraries.
So far, we have only tried to make it work with source distributions of
OpenSSL, not installed versions.  Getting it to work with installed
versions across all the different platforms will take some time.


> the modules/tls/config.m4 logic here strikes me as quite bogus. what
> is the path being supplied? it peers into a number of subdirectories
> to find the header files, but assumes the libraries are in the
> supplied directory.
> it should also either try to guess the path or bail when just
> --with-ssl is used. the current behavior (using 'yes' as the path)
> is more than a little confusing.
> i'm not familiar enough with how openssl is installed (by default
> or by various distributions) to know what the right thing to do is,
> but on a debian system, the libraries are in /usr/lib and the
> headers in /usr/include/openssl. if a read the current config.m4
> right, i would supply --with-ssl=/usr/include, and a -L/usr/include
> would get added to the link flags. that's obviously wrong.
> jim

Ryan Bloom               
406 29th St.
San Francisco, CA 94131

View raw message