httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Nichols <t...@team.citx.net>
Subject Make install fails on libtool when compiled as a library
Date Tue, 10 Apr 2001 21:22:08 GMT
Hi all. I'm compiling the httpd 2.0.16 beta on BSDI 4.2 with this
configure:
unixODBC-2.0.4 on system
Postgresql 7.0.3  on system and running fine


./configure --prefix=/var/www \
--enable-rule=SHARED_CORE \
--enable-rule=SHARED_CHAIN \
--enable-module=vhost_alias \
--enable-module=rewrite \
--enable-module=usertrack \
--enable-module=so \
--enable-module=setenvif

This configures okay.
Then I run a Make, which completes okay.
When I run make install, I get this:

Making install in srclib
Making install in apr
Making all in lib
Making all in strings
Making all in passwd
Making all in tables
Making all in file_io/unix
Making all in network_io/unix
Making all in threadproc/unix
Making all in misc/unix
Making all in locks/unix
Making all in time/unix
Making all in mmap/unix
Making all in shmem/unix
(cd mm && make libmm.la)
`libmm.la' is up to date.
Making all in i18n/unix
Making all in user/unix
Making all in dso/unix
if [ ! -d /var/www/include ]; then  ./build/mkdir.sh /var/www/include;
fi;  cp include/*.h /var/www/include;  if [ ! -d /var/www/lib ]; then
./build/mkdir.sh /var/www/lib;  fi;  libtool --mode=install cp libapr.la
/var/www/lib
libtool: not found
*** Error code 1

Stop.
*** Error code 1

Stop.
*** Error code 1

Stop.

The above installation method works fine with Apache_1.3.17 on the same
machine. Any suggestions?

Mime
View raw message