httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@covalent.net>
Subject Re: daedalus apache-2.0 problem
Date Thu, 08 Mar 2001 23:16:14 GMT

Can I ask a stupid question?  Has anybody been able to reliably duplicate
this bug?  I have tried on my linux box, and I can't.  I have even tried
the exact same request that caused it to bomb on daedalus.  I would like
to test on my freebsd machine, but it has a low priority.  Until this bug
can actually be reproduced, arguing about what causes it is not very
helpful IMHO.

I have look at the corefiles in some great detail, and they just don't
provide enough information to actually determine what is going on.

Ryan

On 8 Mar 2001, Jeff Trawick wrote:

> Cliff Woolley <cliffwoolley@yahoo.com> writes:
>
> > On Thu, 8 Mar 2001, Jeff Trawick wrote:
> >
> > > An assert pops in ap_getline().  The assert attempts to verify that
> > > the brigade is empty once we've read an entire line.  In this case
> > > however an eos bucket is still in the brigade.
> >
> > That's the same one seen in corefiles 4 and 9 on daedalus.  It's not
> > always an EOS bucket, though.  In corefile 4, it's an empty heap bucket.
> > In corefile 9, it's a 10-byte heap bucket.  Clearly something screwy is
> > going on.
>
> I don't see the connection unless there is some bug in the ring macros
> which adds arbitrary buckets to the ring/brigade.
>
> I don't see why an eos bucket would even be in the brigade here.  I
> would have thought that the HTTP input filter would do a read(), grab
> the rest of the data from the client, and before thinking it should do
> another read() (to hit EOF) it would return a brigade to the caller.
>
> --
> Jeff Trawick | trawickj@bellsouth.net | PGP public key at web site:
>        http://www.geocities.com/SiliconValley/Park/9289/
>              Born in Roswell... married an alien...
>
>


_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message