httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@covalent.net>
Subject Re: Apache 2.0.12 ready for testing
Date Mon, 26 Feb 2001 14:24:55 GMT

> I am currently getting this when doing a full
>
>  make clean >/dev/null
>  ./buildconf &&
>  ./config.nice
>
> (end of log:)
>   ...
>   srclib/apr configured properly
>   loading cache ./config.cache
s>   configuring package in srclib/apr-util now
>   loading cache ../.././config.cache
>   checking for gcc... (cached) gcc
>   checking whether the C compiler (gcc  ) works... yes
>   checking whether the C compiler (gcc  ) is a cross-compiler... no
>   checking whether we are using GNU C... (cached) yes
>   checking whether gcc accepts -g... (cached) yes
>   checking for mawk... (cached) gawk
>   checking for rm... (cached) rm
>   checking for APR... /home/com5/martin/pgtm0035/apachen/X/apr/include
>   checking how to run the C preprocessor... (cached) gcc -E
>   checking for chosen DBM type... sdbm (default)
>   cd: can't cd to ../expat-lite
>   checking for Expat in ../expat-lite... no
>   configure: error: Expat was not found (or recognized) in "../expat-lite"
>   configure failed for srclib/apr-util
>
> where this is my config.nice (which used to work until a few days ago
> in my nightly build):
>
> #! /bin/sh
> #
> # Created by configure
>
> "./configure" \
> "--prefix=/home/www/SERVER/apa20" \
> "--with-mpm=prefork" \
> "--with-port=8007" \
> "--enable-so" \
> "--enable-env=shared" \
> "--enable-setenvif=shared" \
> "--enable-unique_id=shared" \
> "--enable-mime=shared" \
> "--enable-mime_magic=shared" \
> "--enable-negotiation=shared" \
> "--enable-alias=shared" \
> "--enable-rewrite=shared" \
> "--enable-userdir=shared" \
> "--enable-speling=shared" \
> "--enable-dir=shared" \
> "--enable-autoindex=shared" \
> "--enable-access=shared" \
> "--enable-auth=shared" \
> "--enable-auth_dbm=shared" \
> "--enable-auth_db=shared" \
> "--enable-auth_anon=shared" \
> "--enable-digest=shared" \
> "--enable-headers=shared" \
> "--enable-cern_meta=shared" \
> "--enable-expires=shared" \
> "--enable-asis=shared" \
> "--enable-include=shared" \
> "--enable-cgi=shared" \
> "--enable-cgid=shared" \
> "--enable-actions=shared" \
> "--enable-status=shared" \
> "--enable-info=shared" \
> "--enable-log_config=shared" \
> "--enable-usertrack=shared" \
> "--enable-dav=shared" \
> "--enable-dav_fs=shared" \
> "--enable-imap=shared" \
> "--disable-proxy" \
> "--enable-mmap_static=shared" \
> "--enable-tls=static" \
> "--with-ssl=/usr/local/ssl/include" \
> "$@"
>
> What am I doing wrong?

Probably nothing.  :-(  Could you try with HEAD and see if it still
happens.  expat-lite was just integrated into APR-util, and the work may
not have been completed when I tagged.  2.0.12 is already dead however, as
is 2.0.13.  Hopefully Greg will move expat into APR-utils soon.

Ryan

_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message