httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Havard" <bri...@kheldar.apana.org.au>
Subject Re: Can I take down apache.org?
Date Fri, 16 Feb 2001 00:40:22 GMT
On Thu, 15 Feb 2001 06:30:46 -0800 (PST), rbb@covalent.net wrote:

>
>> I've just observed a bug, apparently in mod_included, that's causing
>> scrambled output. It gets the first 4k of the body right but after 4k it
>> jumps back to the 2k point. This is on an 18k file.
>> 
>> If I try a 50k file I get 16k ok but then it repeats the 8->16k data up to
>> the 50k total.
>> 
>> If I try a 100k file I get no output at all, not even the header.
>> 
>> If I remove the INCLUDES filter everything works as it should. BTW, the
>> FilesMatch directive in httpd-std.conf for INCLUDES doesn't work for me, I
>> had to change it to <FilesMatch "\.shtml$">
>
>Could you put those files someplace?  I have been using FAQ.html to test
>the server, and everything works.  It looks like you have a better test.

Never mind, it appears to be in the APR buffering code. A test program that
reads the file using apr_file_getc() shows the same problem. Don't know why
it's just appeared now though. Will dig further.....

-- 
 ______________________________________________________________________________
 |  Brian Havard                 |  "He is not the messiah!                   |
 |  brianh@kheldar.apana.org.au  |  He's a very naughty boy!" - Life of Brian |
 ------------------------------------------------------------------------------


Mime
View raw message