httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@covalent.net
Subject We're not on 2.0 :-(
Date Tue, 09 Jan 2001 06:00:49 GMT

I had moved us to 2.0 for about ten minutes, but we were seg faulting
pretty regularly, so I moved us back to 1.3.  I will look into the seg
faults tomorrow.  I would mention that the server was working well other
than the seg faults.  We don't seem to stream data as well as 1.3 did, but
I think that's because in 1.3 we sent data when we had 4k, in 2.0 we wait
to send 9k at a time.  This will have an effect on the perceived
performance.

We have another problem, but this one should be relatively easy to
solve.  bugs.apache.org will not work with the code as it exists
today.  The problem is easy, suexec is compiled against apr, but we use
libtool, so nothing is easy.  :-)

These are the important error messages:

[Mon Jan 08 21:48:41 2001] [error] [client 63.248.250.243] Premature end
of script headers: /da1/www/bugs.apache.org/index.cgi
[Mon Jan 08 21:48:41 2001] [error] [client 63.248.250.243]
/usr/libexec/ld-elf.so.1: Shared object "libaprutil.so.0" not found

Basically, this is happening because libaprutil.so isn't installed, and
suexec hasn't got a clue where to find it.  We just need to fix the
linking.  Any libtool experts want to take this?

Ryan
_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message