httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@algroup.co.uk>
Subject Re: Grief, but good grief?
Date Mon, 15 Jan 2001 00:24:29 GMT
William A. Rowe, Jr." wrote:
> 
> > From: William A. Rowe, Jr. [mailto:wrowe@rowe-clan.net]
> > Sent: Friday, January 12, 2001 11:00 PM
> >
> > Would a macro, with a friend, declared as:
> >
> > #define AP_DECLARE_MODULE (mod) \
> > module AP_MODULE_DECLARE_DATA mod = { \
> > mod = { \
> > STANDARD20_MODULE_STUFF, \
> > #mod,
> 
> Whoops... try
> 
> #define AP_DECLARE_MODULE (mod) \
> module AP_MODULE_DECLARE_DATA mod = { \
>     STANDARD20_MODULE_STUFF, \
>     #mod,
> 
> for clarity's sake alone, not to mention it was wrong.

Yes! This is what I was talking about re: unique names. BTW, changing
this would affect hooks, coz they use the module names for ordering.

Cheers,

Ben.

--
http://www.apache-ssl.org/ben.html

"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff

Mime
View raw message