httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@algroup.co.uk>
Subject Re: Hook name?
Date Mon, 01 Jan 2001 19:13:22 GMT
rbb@covalent.net wrote:
> 
> +1.  It looks like this was a mistaken change.  Take a look at Revision
> 1.17.  It looks like this was a part of a name change at some
> point.  However, before the name change this was g_szCurrentHookName,
> which really should have always been #name IMHO.

Nope, ap_debug_module_name is actually correct (its the name of the
module currently registering hook functions, which is needed for
sorting, of course). So, no change needed - it's just a somewhat
misleading name - the functionality is nothing to do with debugging,
it's vital to correct operation. I guess we should rename it to, say
ap_current_hooking_module, or something.

Cheers,

Ben.

> 
> Ryan
> 
> On Mon, 1 Jan 2001, Ben Laurie wrote:
> 
> > In ap_hooks.h, we have:
> >
> >     pHook->szName=ap_debug_module_name; \
> >
> > why??? Shouldn't it be:
> >
> >     pHook->szName=#name; \
> >
> > Cheers,
> >
> > Ben.
> >
> > --
> > http://www.apache-ssl.org/ben.html
> >
> > "There is no limit to what a man can do or how far he can go if he
> > doesn't mind who gets the credit." - Robert Woodruff
> >
> >
> 
> _______________________________________________________________________________
> Ryan Bloom                              rbb@apache.org
> 406 29th St.
> San Francisco, CA 94131
> -------------------------------------------------------------------------------

--
http://www.apache-ssl.org/ben.html

"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff

Mime
View raw message