httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [PATCH] - Userdir broken in Apache 1.3.16 for NetWare...
Date Thu, 25 Jan 2001 02:29:14 GMT
I want to review this patch carefully - please hold the tarball, Jim, till 9pm
PST ... I must help my son on something, I will be on this in .5 hour.

----- Original Message -----
From: "Brad Nicholes" <BNICHOLES@novell.com>
To: <new-httpd@apache.org>; <wrowe@rowe-clan.net>
Sent: Wednesday, January 24, 2001 6:00 PM
Subject: [PATCH] - Userdir broken in Apache 1.3.16 for NetWare...


Bill,
     It appears that the patch only cleaned up half of the problem.  I left out the part that
actually checks for an absolute path
in MOD_USERDIR.c.  I have attached the patch here for MOD_USERDIR.  We had the same problem
as WIN32.  Translate_Userdir() could not
tell the difference between an absolute path and a URL.  I retested the full patch and it
appears to have solved the problem.

thanks,
Brad

>>> wrowe@rowe-clan.net Wednesday, January 24, 2001 9:46:34 AM >>>
Brad,

  very nice patch ... affects only the Netware code path.  Note the first part
in http_main.c was nearly applied before (I notice you added the chdir after I
reviewed and applied that part of the patch some time ago.  Check it closely.)

  Please, though it won't break anyone else, please ack that you are able to
perform a clean checkout, build, and run (and if you report that the userdir
problem is gone, I'll close the two PR's with invitations to grab the forthcoming
1.3.17 version.)

Bill






Mime
View raw message