httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@covalent.net
Subject Re: We are NOT ready for a beta.
Date Fri, 22 Dec 2000 21:18:27 GMT

> On Thu, 21 Dec 2000 rbb@covalent.net wrote:
> > The locus downtime right now seems to be because of Apache 2.0.  I turned
> > on 2.0 at about 10:30, and it worked just fine for about fifteen
> > minutes.  Then at just about 10:45, the machine stopped responding to
> > everything.  I am not sure what the issue is, because this doesn't happen
> > on any of my machines when I run Apache.  
> 
> Are we using FreeBSD's kernel threads, or userland threads?  I'm wondering
> if FreeBSD's kernel threads have problems.  Maybe trying the prefork mpm
> would find that out.

Last night we were running the prefork MPM, because I was thinking along
the same lines.  :-(

> Does anyone have a test harness that can simulate actual load,
> particularly on FreeBSD, perhaps using some of the packet-shaping
> tools like dummynet?  I mean, Apache's not getting *that* much traffic at
> night, maybe 10 req's a second, during the day upwards of 40 or 50.  

Right now, I am trying to load all of the modules and just run AB against
a machine to see if I can duplicate the problem.  I'll report back
soon-ish.  BTW, I am going away for the weekend, so we probably won't make
any progress until Tuesday.

Ryan

_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message