httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Tchepannou ...@rbg.informatik.tu-darmstadt.de>
Subject Re: Apache + PHP4 Installation problem...
Date Thu, 21 Dec 2000 01:13:36 GMT
TOKILEY@aol.com wrote:

> Eric...
> Not sure where you got your PHP installation instructions
> but what you are using isn't going to work.
>
> I believe the first --configure command needs to have
> the path to Apache source and not the target install
> dir /usr/local
>
> Go to THIS url on the official PHP site...
> http://php.net/manual/nl/install.unix.php

THANKS A LOT!!!!!
NOW IT WORKS.
first it did not, I found out that on the command
./configure --with-mysql --with-apache=../apache_1.3.x --enable-track-vars
I had not to add a "/" at the end of the directory name (what is done
automatically because I used the TAB) and add the mysql path too.
Once again THANKS I had very hard times trying to install this PHP



>
>
> Page title is: Manual Installation on UNIX systems.
>
> Scroll down 1 page and the 'Apache Module' section
> begins.
>
> Just follow the 18 steps listed there and all should be well.
> If that doesn't work... contact PHP.
> The problem has nothing to do with Apache.
>
> Yours...
> Kevin Kiley
> CTO, Remote Communications, Inc.
>
> In a message dated 00-12-20 10:16:45 EST, Eric writes...
>
> > Subj:  Apache + PHP4 Installation problem...
> >  Date:    00-12-20 10:16:45 EST
> >  From:    et@rbg.informatik.tu-darmstadt.de (Eric Tchepannou)
> >  Sender:  et@mailserver1.hrz.tu-darmstadt.de
> >  Reply-to:    new-httpd@apache.org
> >  To:  new-httpd@apache.org (new-httpd@apache.org)
> >
> >
> >  Hi everybody
> >
> >  I am quite new to this Mailing list, and hope to find here the necessary
> >
> >  help in order to be able to install PHP4 as an Apache Module. I have to
> >  say that I am working on it since almost a week...:-(
> >  Here is how I proceeded :
> >
> >  I first compiled PHP4 :
> >  $ ./configure --with-mysql=/usr/local/mysql...
> >  --with-apache=/usr/local/apache...
> >  $ make
> >  $ make install
> >
> >  that created a php4 directory under /path/to/apache/src/modules/
> >
> >  Then I started with Apache:
> >  $ ./configure --activate-module=src/modules/php4/libmodphp4.a
> >  --enable-module=so
> >  $ make
> >
> >  and it ended with this errror mssages :
> >
> >  <=== src/modules/standard
> >  ===> src/modules/php4
> >  gcc -c  -I../../os/unix -I../../include  /opt/php-4.0.3pl1/Zend/
> >  -DHPUX10 -DUSE_HSREGEX -DUSE_EXPAT -I../../lib/expat-lite `../../apaci`
> >  mod_php4.c
> >  mod_php4.c:28: zend.h: No such file or directory
> >  mod_php4.c:29: php.h: No such file or directory
> >  mod_php4.c:30: php_variables.h: No such file or directory
> >  mod_php4.c:47: php_ini.h: No such file or directory
> >  mod_php4.c:48: php_globals.h: No such file or directory
> >  mod_php4.c:49: SAPI.h: No such file or directory
> >  mod_php4.c:50: php_main.h: No such file or directory
> >  mod_php4.c:52: zend_compile.h: No such file or directory
> >  mod_php4.c:53: zend_execute.h: No such file or directory
> >  mod_php4.c:54: zend_highlight.h: No such file or directory
> >  mod_php4.c:55: zend_indent.h: No such file or directory
> >  mod_php4.c:57: ext/standard/php_standard.h: No such file or directory
> >  make[4]: *** [mod_php4.o] Error 1
> >  make[3]: *** [all] Error 1
> >  make[2]: *** [subdirs] Error 1
> >  make[2]: Leaving directory `/usr/local/apache_1.3.14/src'
> >  make[1]: *** [build-std] Error 2
> >  make[1]: Leaving directory `/usr/local/apache_1.3.14'
> >  make: *** [build] Error 2
> >
> >  I found out that the Zend*.h files are under /opt/php-4*/Zend. So should
> >
> >  I edit the Makefile?
> >
> >
> >  PS : I am working on a HP-UX 10.20, with PHP 4.0.3 and Apache 1.3.14
> >
> >
> >  Yours, Eric Tchepannou

Mime
View raw message