httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maurizio" <mauri...@dreamtech-it.com>
Subject help to compile APACHE + PHP4 in QNX4.25
Date Tue, 26 Dec 2000 17:15:17 GMT
hello,

I have compiled Apache 1.3.14 for QNX.
Now I'm trying to recompile it with PHP4 module. I have some errors because of some redefinition
in include files and also for some diference in the source sintax. I tried to create the libphp4.a
with gcc but when I recompile Apache I have an undefined symbol php4_module. I think the problem
was in the different compiler used: PHP was compiled with gcc and APACHE with WATCOM. 
How can I solve this. Has someone used PHP + APACHE in QNX?

I also tried to compile Apache 2.0a9 but the configure seems ignoring QNX. These are some
output lines :

loading cache ./config.cache
checking host system type... Invalid configuration `i386-qnx-qnx425': system `qnx425' not
recognized

checking target system type... Invalid configuration `i386-qnx-qnx425': system `configure:773:
checking build system type
configure:2078: checking for mawk
configure:2110: checking for gcc
configure:2223: checking whether the C compiler (gcc  ) works
configure:2239: gcc -o conftest    conftest.c  1>&5
configure:2265: checking whether the C compiler (gcc  ) is a cross-compiler
configure:2270: checking whether we are using GNU C
configure:2298: checking whether gcc accepts -g
configure:2330: checking how to run the C preprocessor


......

.....



checking for BSD-compatible nm... (cached) nm
loading cache ./config.cache within ltconfig
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
hreads_cflags
configure:7439: checking for pthreads_lib
configure:7507: checking for which threading library to use






could someone please help me ?

Thank You

Maurizio Cauci
DREAMTECH di Cauci Maurizio
Via Ronchetti, 2 - 21013 Gallarate (VA)
www.dreamtech-it.com

Mime
View raw message