httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Stoddard" <>
Subject Re: cvs commit: apache-2.0/src/main http_core.c http_protocol.c
Date Tue, 03 Oct 2000 03:01:13 GMT
A little clarification...

----- Original Message -----
From: "Bill Stoddard" <>
To: <>
Sent: Monday, October 02, 2000 10:41 PM
Subject: Re: cvs commit: apache-2.0/src/main http_core.c http_protocol.c

> >
> > > Yes, I suspect it will need to be "done" by the core filter
> > > (or, to use a better term for it, the message envelope filter)
> > > since that is where chunks need to be coalesced as well.  It
> > > was my impression that Bill's filter would be placed by the
> > > core filter and not by other filters, given that it is static
> > > to http_protocol.c.  That is equivalent to buffering within
> > > the core filter.
> >
> > Being a static function doesn't mean it must be placed by the core
> > filter.  As long as the function can be named at some point, it can be
> > added by anybody.  This is why I want this as a part of the core
> > filter.  Doing the buffering in multiple places, or anyplace other than
> > the core filter is a bit bogus.
> I disagree, but only until you can convince me otherwise.  Buffering in the 'core' as
in http_core
> is fine. Buffering needs to go in before the chunking filter,

Rewrite as "Coalescing needs to go in before the chunking filter,..." And doing a bit of buffering
(collecting buckets and saving them in filter->ctx) is necessary to do coalescing. Doing
both in
buffer_filter is not all that difficult.

> one way or the other, either in the
> buffer filter or in the routines that module writers use to do network i/o. The buffer_filter
> seemed a logical first stab and maybe even the best solution.
Maybe I should rename it to 'coalesce_filter' :-). That more closely describes its function
by your


View raw message