httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Isn't BUCKETS name a little lame? ( Was apr_sucks )
Date Mon, 14 Aug 2000 04:14:48 GMT

>  On Sun, 13 Aug 2000, Roy T. Fielding wrote:
>  > I've kept mostly quiet on this out of respect of others and the
>  > need to focus on my dissertation defense, but since it is seriously
>  > coloring my general mood today, I think I need to say it in writing:
>  > 
>  >    the apr_ prefix seriously fucking pisses me off
>  > 
>  > Just my opinion.
>  > 
>  > ....Roy
>  > 
> In a message dated 00-08-14 03:01:05 EDT, Dean Gaudet responded...
> +1
>  capricious symbol name changes are totally lame.
>  what happens when someone says "hey i want to use filters and
>  bucket-brigades in my code, could you put them into a library?"  is the
>  group going to rename all the existing symbols apr_ or apf_ or apb_ or
>  something?
>  -dean

Speaking of 'mostly keeping quiet out of respect for others' ( Roy )
and 'capricious names that are totally lame' ( Dean )... I the only one who thinks that actually naming what will 
probably be a very sophisticated filtering interface a 'bucket brigade'
to be about the height of lameness itself?

People need concepts they can relate to and BUCKETS and BUCKET BRIGADE 
are probably good fall-back 'it sort of works like this' terms regarding what 
the proposed filtering design is actually DOING most ( but not all ) of the 
but does that mean that's what it has to be NAMED right down to actual 
function names?

Example: A kernel level task queue is a lot like a merry-go-round complete 
a ticket taker and reserved 'horses' for higher priority riders... but I don't
see anyone seriously coming up with functions like this...


It just sounds a little junior high school and has a certain definable
notch mark on the laugh-o-meter.

The whole 'bucket brigade' pass-the-stuff-along example is simply 
what Roy used to try and explain what he was talking about but
now it has ascended ( without due consideration ) to an actual naming
convention and maybe it's time to think about whether it's really 
appropriate before you get any deeper into it.

Keep 'bucket brigade' as a back-room way to explain the concept.
Pick something ELSE for the actual function names.

Besides... I think you are going to discover by the time the dust
clears that the 'bucket brigade' comparison is not going to 'hold
water' ( pun intended ) under all filtering circumstances and when
it is finished you will not only be stuck with a naming 
convention that is a little lame but doesn't even really explain what
is happening under all circumstances.

Better to keep the API names generic up front.

Just my opinion, as well, of course... but tonight seems to be the 
night for them.

Kevin Kiley
CTO, Remote Communications, Inc. - Online Internet Content Compression Server

View raw message