httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: hooks
Date Wed, 05 Jul 2000 21:06:23 GMT

> > Btw., does anybody disagree with changing the update functions in
> > md5 and sha1 to ap_MD5Update_ascii(), ap_MD5Update_binary(),
> > ap_SHA1Update_ascii(), and ap_SHA1Update_binary()? I.e. to better
> > reflect which are ascii and which binary (the ascii forms first
> > translate the characters as necessary to ascii). And similarly
> > for ap_base64. Currently we have ap_SHA1Update() and
> > ap_SHA1Update_binary() in 1.3.
> Euh... why not call it ap_MD5Update_xlate() and pass an xlate pointer? Seems
> a bit better than hard-wiring to ascii/ebcdic and using just one of those
> two charsets.

Huh.  The translation is already done.  I was under the impression that we
currently have two functions, ap_SHA1Update and ap_SHA1Update_binary.  I
thought the suggestion was to just change ap_SHA1Update to
ap_SHA1Update_ascii.  The translation only makes sense if we are dealing
with ascii data IMO, and that is setup before hand and is taken care of
automagically.  What am I missing?


Ryan Bloom               
406 29th St.
San Francisco, CA 94131

View raw message