httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <trawi...@bellsouth.net>
Subject problem -- can't resolve core symbols when loading a dso
Date Fri, 28 Jul 2000 16:40:42 GMT
I need to be hit with a clue-by-4, but I'm not sure which one.  I 
suspect either a problem with my configure invocation or with our
libtool usage which is preventing dso load from resolving symbols that 
live in httpd.

Linux results:

At LoadModule time, I get errors like this when trying to load a dso:

Cannot load /dl/apache/apache-2.0/src/modules/standard/.libs/mod_auto
index.so into server: /dl/apache/apache-2.0/src/modules/standard/.lib
s/mod_autoindex.so: undefined symbol: ap_set_string_slot

For a couple of other modules I've tried (mod_cgi and mod_include),
core_module is the first unresolved symbol found.

configure invocation:

./configure --with-debug --prefix=/tmp/apache-2.0  --with-mpm=prefork 
--enable-module=status --enable-so --enable-mods-shared=cgi --enable-
mods-shared=include --enable-mods-shared=autoindex

Victor tried it on AIX with somewhat different results: a dso abended 
(I don't know what type -- SIGSEGV?  SIGILL?) when trying to call
something in httpd.

Any ideas?
-- 
Jeff Trawick | trawick@ibm.net | PGP public key at web site:
     http://www.geocities.com/SiliconValley/Park/9289/
          Born in Roswell... married an alien...

Mime
View raw message