httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@lnd.com>
Subject RE: default timeout values
Date Fri, 23 Jun 2000 18:00:55 GMT
> From: rbb@covalent.net [mailto:rbb@covalent.net]
> Sent: Friday, June 23, 2000 12:52 PM
> 
> > +1 on Ryan's reply and design to use usecs.
> > 
> > Now, I have a -new- proposal that we adopt:
> > 
> >  ap_time_short_delta_t 
> > 
> > Comments on changing this type name for clarity?  (I just propose
> > delta instead of interval since it's a shorter word, that's all.)
> 
> I really don't think this helps clarity any, sorry.  :-}  I also don't
> mind replying to messages on the list with:
> 
> "This topic has been discussed before, please see the archives for Jun
> 2000, and search for interval_time."

Fair enough, but I'd suggest that if 3 coders notice this 'bug' (we are
up to two already), that we have a doc problem or clarity problem.  Let's
not waste everyone's time unwinding the same restriction.
 
> I really think we are fine the way things are now.  If we want room to
> grow into the future, I think we can just change the def of
> ap_interval_time_t.  All this requires is a recompile to move 
> from 32 -> 64 bit values.

Here I disagree.  32 bits is a good thing for optimization, IMHO.  If we
ever did extend to hours or days, that would and should be a different 
type.  Declaring it now tells the new coder to APR that we did think
this through, and these functions are all in short time intervals.

Bill

Mime
View raw message