httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@covalent.net
Subject Re: LoadModule troubles
Date Fri, 19 May 2000 12:58:44 GMT

Doug, could you send a small config file that duplicaets this, just so I
can understand the big issue here.

Ryan

On Fri, 19 May 2000, Doug MacEachern wrote:

> *curr_parent == NULL == segv, the patch below makes everything happy for
> me, but not sure it's the right fix.
> 
> 0x8063ade in ap_build_config_sub (p=0x8099c34, temp_pool=0x80b9d34, 
>     l=0xbfffd558 "LoadModule perl_module libexec/libmodperl.so", 
>     parms=0xbffff5b8, current=0xbfffd550, curr_parent=0xbfffd554)
>     at http_config.c:877
> 877                     (*curr_parent)->first_child = (*current);
> (gdb) where
> #0  0x8063ade in ap_build_config_sub (p=0x8099c34, temp_pool=0x80b9d34, 
>     l=0xbfffd558 "LoadModule perl_module libexec/libmodperl.so", 
>     parms=0xbffff5b8, current=0xbfffd550, curr_parent=0xbfffd554)
>     at http_config.c:877
> #1  0x8063e58 in ap_build_config (parms=0xbffff5b8, p=0x8099c34, 
>     temp_pool=0x80b9d34, conftree=0xbffff580) at http_config.c:1034
> #2  0x806434b in ap_process_resource_config (s=0x809a5c4, 
>     fname=0x808bf2f "conf/httpd.conf", p=0x8099c34, ptemp=0x80b9d34)
>     at http_config.c:1285
> #3  0x8064850 in ap_read_config (process=0x8097c54, ptemp=0x80b9d34, 
>     confname=0x808bf2f "conf/httpd.conf") at http_config.c:1530
> #4  0x80685da in main (argc=1, argv=0xbffff6a4) at http_main.c:379
> (gdb) p *curr_parent
> $1 = (ap_directive_t *) 0x0

_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message