httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: cvs commit: apache-2.0/src/modules/standard mod_access.c mod_alias.c mod_asis.c mod_auth.c mod_auth_anon.c mod_auth_digest.c mod_autoindex.c mod_cern_meta.c mod_cgi.c mod_cgid.c mod_dir.c mod_echo.c mod_env.c mod_expires.c mod_file_cache.c mod_headers.c mod_imap.c mod_include.c mod_info.c mod_log_config.c mod_mime.c mod_negotiation.c mod_rewrite.c mod_setenvif.c mod_so.c mod_speling.c mod_status.c mod_unique_id.c mod_usertrack.c mod_vhost_alias.c
Date Sat, 27 May 2000 21:02:00 GMT
On Fri, 26 May 2000 rbb@covalent.net wrote:
>...
> On 27 May 2000 wrowe@locus.apache.org wrote:
>...
> >      /* Hooks */
> >   -AP_DECLARE_HOOK(int,header_parser,(request_rec *))
> >   -AP_DECLARE_HOOK(void,post_config,
> >   +AP_DECLARE_HOOK(API_EXPORT,int,header_parser,(request_rec *))
> >   +AP_DECLARE_HOOK(API_EXPORT,void,post_config,
> >    	     (ap_pool_t *pconf,ap_pool_t *plog,ap_pool_t *ptemp,server_rec *s))
> >   -AP_DECLARE_HOOK(void,open_logs,
> >   +AP_DECLARE_HOOK(API_EXPORT,void,open_logs,
> >    	     (ap_pool_t *pconf,ap_pool_t *plog,ap_pool_t *ptemp,server_rec *s))
> >   -AP_DECLARE_HOOK(void,child_init,(ap_pool_t *pchild, server_rec *s))
> >   +AP_DECLARE_HOOK(API_EXPORT,void,child_init,(ap_pool_t *pchild, server_rec *s))
> 
> Every single hook is being declared API_EXPORT.  This seems silly to
> me.  Can't we just use API_EXPORT in the macro definition?

That's what I said, too. Consider me a "-1" on this part of the commit.
Until we have a *need* for a different linkage, this parameter should not
be included. *When* that need arises, then we can add a second set of
macros (but leave these alone!).

> >   -#ifndef MODULE_VAR_EXPORT
> >   -#define MODULE_VAR_EXPORT
> >   +#ifndef MODULE_EXPORT_VAR
> >   +#define MODULE_EXPORT_VAR
> >    #endif
> >   -#ifndef API_VAR_EXPORT
> >   -#define API_VAR_EXPORT
> >   +#ifndef API_EXPORT_VAR
> >   +#define API_EXPORT_VAR
> >    #endif
> 
> These are name changes for the sake of name changes, blech.

Agreed.

If we're going to change the names, then it really should be to something
like:

  AP_MODULE_EXPORT_VAR
  AP_EXPART_VAR

i.e. namespace protection

> I am basically -1 for this whole commit unless somebody can explain why
> the name change was necessary.

I certainly can't explain...

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/


Mime
View raw message