httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <>
Subject anybody having problems with --with-module?
Date Mon, 22 May 2000 01:30:05 GMT
Perhaps this sounds crazy, but it seems that ap_config_auto.h is hosed
when I use --with-module=xxx.  The hosed ap_config_auto.h is almost
the same as 

[trawick@k5 src]$ diff include/ include/ap_config_auto.h
> /* include/ap_config_auto.h.  Generated automatically by configure.  */
> #define STDC_HEADERS 1
< #undef HAVE_CTYPE_H
> #define HAVE_CTYPE_H 1
< #undef HAVE_STDLIB_H
> #define HAVE_STDLIB_H 1
< #undef HAVE_STRING_H
> #define HAVE_STRING_H 1

The bogus ap_config_auto.h seems to be related to a sed error message,
shown below.

I run configure like this:

./configure --with-debug --enable-module=cgi --prefix=/tmp/apache-2.0  --with-mpm=prefork
--enable-module=status --with-module=/dl/apache/mod_charset_lite.c

Output from configure telling me that mod_charset_lite was added...

checking whether to enable mod_setenvif... yes
checking whether to enable mod_echo... yes
checking for extra modules... /dl/apache/mod_charset_lite.c     mod_charset_lite.c
added /dl/apache/mod_charset_lite.c
checking for target platform... unix
checking for setsid... (cached) yes 

See this bad output showing a sed error:

creating modules/example/Makefile
creating modules/mpm/Makefile
creating modules/mpm/prefork/Makefile
creating modules/standard/Makefile
creating modules/extra/Makefile
creating os/unix/Makefile
creating Makefile
creating ap/Makefile
creating lib/Makefile
creating main/Makefile
creating modules/Makefile
creating os/Makefile
creating support/Makefile
creating ./config.status
sed: -e expression #1, char 1: Missing command              <----------------
creating support/apxs
creating include/ap_config_auto.h
include/ap_config_auto.h is unchanged
./include/ap_config_path.h unchanged
configuring in lib/pcre                 

My first wild goose chase was thinking it had something to do with
using EXTRA_CFLAGS...  Now I find that simply toggling
--with-module=/whatever toggles the bad behavior (sed error + bogus
ap_config_auto.h).  More debugging required...

Jeff Trawick | | PGP public key at web site:
          Born in Roswell... married an alien...

View raw message