httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: EXTRA_CFLAGS
Date Wed, 03 May 2000 12:00:47 GMT
The concept of "EXTRA_*" isn't enabled yet... I was still unsure
whether the default action should be to append command-line settings
of, for example, CFLAGS, to that set by hints.m4, or simply to
use the command-line ones _instead_ of what hints.m4 says (which
is how it currently works).

I can see both arguments. It's easy to change, or implement
EXTRA_*. We'll see which makes the most sense and is more
obvious to the casual user... I'm leaning towards EXTRA_*
at present, but I still not sure :)

Jeff Trawick wrote:
> 
> Is EXTRA_CFLAGS broken?
> 
> Prior to Jim's hints.m4:
> 
>   CFLAGS='-g -U_NO_PROTO' ./configure blah
> 
> I changed Jim's hints.m4 file to set CFLAGS to '-U_NO_PROTO' and
> thought I should use 
> 
>   EXTRA_CFLAGS='-g' ./configure blah
> 
> Unfortunately, EXTRA_CFLAGS doesn't seem to be used during
> configuration or build.  Zapped out in config_vars.mk or whatever
> builds it?
> 
> -- 
> Jeff Trawick | trawick@ibm.net | PGP public key at web site:
>      http://www.geocities.com/SiliconValley/Park/9289/
>           Born in Roswell... married an alien...
> 


-- 
===========================================================================
   Jim Jagielski   [|]   jim@jaguNET.com   [|]   http://www.jaguNET.com/
                "Are you suggesting coconuts migrate??"

Mime
View raw message