httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <dr...@jetnet.co.uk>
Subject Re: FreeBSD 3.4 speaks up on Apache 2.0 :)
Date Tue, 09 May 2000 08:47:55 GMT
That shouldn't be necessary, but is pcre linking against a library that we
haven't used before?


----- Original Message -----
From: <rbb@covalent.net>
To: <new-httpd@apache.org>; <trawickj@bellsouth.net>
Sent: Monday, May 08, 2000 12:20 PM
Subject: Re: FreeBSD 3.4 speaks up on Apache 2.0 :)


> On Mon, 8 May 2000, Jeff Trawick wrote:
>
> > /bin/sh
/usr/home/trawick/apache/apache-2.0/src/libtool --silent --mode=link
gcc  -g -O2 -pthread -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wmis
sing-declarations  -o httpd  modules.lo buildmark.lo
modules/standard/libapachemod_env.la
modules/standard/libapachemod_log_config.la
modules/standard/libapachemod_mime.la
modules/standard/libapachemod_negotiation.la
modules/standard/libapachemod_include.la
modules/standard/libapachemod_autoindex.la
modules/standard/libapachemod_dir.la modules/standard/libapachemod_cgi.la
modules/standard/libapachemod_asis.la modules/standard/libapachemod_imap.la
modules/standard/libapachemod_actions.la
modules/standard/libapachemod_userdir.la
modules/standard/libapachemod_alias.la
modules/standard/libapachemod_access.la
modules/standard/libapachemod_auth.la
modules/standard/libapachemod_setenvif.la
modules/standard/libapachemod_echo.la
modules/mpm/mpmt_pthread/libmpmt_pthread.la  main/libmain.la
os/unix/libos.la  ap/libap.la  lib/apr/l!
> ibap!
> > !
> > r.a  lib/pcre/libpcre.la  lib/pcre/libpcreposix.la -lcrypt -lcrypt
> > /usr/lib/libc.so.3: warning: mktemp() possibly used unsafely; consider
using mkstemp()
> > /usr/lib/libc.so.3: warning: this program uses gets(), which is unsafe.
> > /usr/lib/libc.so.3: WARNING!  setkey(3) not present in the system!
> > /usr/lib/libc.so.3: WARNING!  des_setkey(3) not present in the system!
> > /usr/lib/libc.so.3: WARNING!  encrypt(3) not present in the system!
> > /usr/lib/libc.so.3: WARNING!  des_cipher(3) not present in the system!
> > /usr/lib/libc.so.3: warning: this program uses f_prealloc(), which is
stupid.
> > trawick@freebie.local:/usr/home/trawick/apache/apache-2.0/src%
> >
> > I'm not sure when this stuff cropped up.  Hopefully I'll get a chance
> > in the next year or so to look into it further...
>
> This stuff all cropped up with the addition of pcre it looks like.  I was
> led to believe this was a stable, good regex library, which is why it was
> in the status file.  Do we want to back out this change?
>
> Ryan
>
>
____________________________________________________________________________
___
> Ryan Bloom                        rbb@apache.org
> 406 29th St.
> San Francisco, CA 94131
> --------------------------------------------------------------------------
-----
>
>


Mime
View raw message