httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: 2.0 naming
Date Mon, 03 Apr 2000 09:40:10 GMT
+1 on all points!

Since the hook stuff is new to 2.0, it doesn't even need to be
grandfathered. The HTTP_* has been around long enough for people to switch
over. If they haven't yet, then screw 'em :-)

Cheers,
-g

On Fri, 31 Mar 2000, Doug MacEachern wrote:

> i'm just starting to play with 2.0, i think all (well, most) macros should
> have an AP_ prefix, e.g.
> HOOK_MIDDLE       -> AP_HOOK_MIDDLE
> MODULE_VAR_EXPORT -> AP_MODULE_VAR_EXPORT
> 
> etc.
> 
> it might also be a good time to remove the backward-compat HTTP_ aliases,
> e.g.
> 
> httpd.h:454:#define DOCUMENT_FOLLOWS    HTTP_OK
> httpd.h:455:#define PARTIAL_CONTENT     HTTP_PARTIAL_CONTENT
> 
> i don't think the HTTP_* macros need an AP_ prefix, but wouldn't complain
> if they did.
> 
> and some names that always bugged me carried over from 1.x:
> 
> ap_hook_check_user_id
>  to
> ap_hook_authentication_checker
> 
> ap_hook_auth_checker
>  to
> ap_hook_authorization_checker
> 
> it might seem painful, but if we want squeeky clean namespace, better now
> than later.  i can make time to implement any of these changes too.
> 

-- 
Greg Stein, http://www.lyra.org/


Mime
View raw message