httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@algroup.co.uk>
Subject Re: minor pollution
Date Fri, 28 Apr 2000 17:05:07 GMT
rbb@covalent.net wrote:
> 
> On Fri, 28 Apr 2000, Bill Stoddard wrote:
> 
> > > * function find_child_by_pid modules/mpm/mpmt_pthread/scoreboard.c:205
> > > this is API_EXPORT-ed, should have an ap_ prefix
> > >
> > > * variable g_bDebugHooks
> > > * variable g_pHookPool
> > > * variable g_szCurrentHookName
> > >
> >
> > I kinda like the idea of globals being named to identify them as such.
> 
> I didn't think he was suggesting getting rid of the g_, just making it
> namespace protected by adding an ap_ in front of it.  But, I could be
> wrong of course.

Speaking as the g_ perpetrator, I would say you add the ap_ after, not
before. i.e. g_ap_bDebugHooks.

BTW, if people like this, I also use s_ for statics (and m_ for members,
but this ain't C++).

Cheers,

Ben.

--
http://www.apache-ssl.org/ben.html

Mime
View raw message