httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodent of Unusual Size <Ken.C...@Golux.Com>
Subject Re: [PATCH] 2nd draft of APR wrapper for iconv
Date Wed, 19 Apr 2000 12:22:12 GMT
Jeff Trawick wrote:
> Beyond what was discussed on the list earlier today, I made several
> additional changes which hopefully are acceptable:
> 1) in honor of Ryan's new ap_cp_XXX function names, I changed:
>    a) the name of the handle type from ap_iconv_t to ap_cp_t
>    b) the name of the header file from apr_iconv.h to apr_cp.h
>    c) the name of the Unix source file from
>       lib/apr/iconv/unix/apr_iconv.c to lib/apr/cp/unix/cp.c

I hate to be a fly in the ointment, but I really am opposed
to dropping the recognisable and meaningful 'iconv' portion
of the names and replacing them with the non-intuitive 'cp'.
This strikes me as a name change for no good reason (:-D)
and I'm -1 on such a non-intuitive naming scheme because of
readability issues.

Particularly if we're using a HAVE_ICONV macro, things which
depend on it should be named likewise.

Sorry I didn't raise this in the original thread.
#ken    P-)}

Ken Coar                    <http://Golux.Com/coar/>
Apache Software Foundation  <>
"Apache Server for Dummies" <http://Apache-Server.Com/>
"Apache Server Unleashed"   <http://ApacheUnleashed.Com/>

View raw message